February 28, 2002

Fake tags trouble! I wanted to end my curling comment with a nice [/hissy fit]. (Replace the square brackets with angle brackets.) Each time I previewed it looked differently, and the actual post is ugly barfage. [more inside]

posted by qbert72 to bugs at 12:21 AM - 6 comments

First preview

 ends up invisible (just like here). I suppose the angle brackets are not converted, so I replace them with the entity names 
</hissy fit>
. Preview is nice. I further edit my comment, hit preview again, and the ampersand in the entity names has been converted too, giving
&lt;/hissy fit&gt;
. So, I take off the
amp;
and post. Ta da!

So, what's the proper way to insert fake code? I know I could just use square brackets and live happily ever after, but I like my things complicated, so please hope me!

posted by qbert72 at 12:31 AM on February 28

<test> = &lt;test&gt; hmm worked for me

posted by riffola at 01:16 AM on February 28

Well it seems to work nicely here... I could have sworn my & turned into & between preview and post...

posted by qbert72 at 02:04 AM on February 28

damn! I meant

&
turned into
&amp;
This is getting really complicated...

posted by qbert72 at 02:10 AM on February 28

qbert72: I can't reproduce the problem you had here or in the original post. So everything's swell, right?

posted by kirkaracha at 07:48 PM on February 28

Well, I guess everything's swell, yes. I shall hope myself from now on. And go to bed earlier.

posted by qbert72 at 10:00 PM on February 28

You're not logged in. Please log in or register.